Get more from your Mavic
The largest Mavic community in the world
Join Us Now

HELP needed... Crystal Sky video Delay...

mdenhartog

New Member
Joined
Sep 14, 2020
Messages
4
Reaction score
2
Age
40
Location
Florida
Ok so I am asking for a friend... Several pilots flying Inspire and Matrice aircraft last week switched over to the Mavic 2 Pro this week to perform power line inspection in residential areas. The thought was that the larger aircraft in residential areas would be less disturbing to the residents and cause less push back for the power company. The lines are lower voltage and they can physically get closer so no need for the larger aircraft anyway. With that logic they purchased from Florida Drone Supply new Mavic 2 sets and Crystal Sky mounts to use their existing Crystal Sky tablets. Those that opted to go with the smart controller or an iPad are not having any issues. But, those that used the Crystal Sky have reported a second or two delays and some as great as 10 seconds getting video signal from the aircraft.

Has anyone heard of this before with the Crystal Sky? I have personally experienced this with lesser quality Ipads and Android tablets when getting loaded down. But not a Crystal Sky, do any of you think length of the USB C cable matters much. I was told most of them are using the cable that came with the DJI Mavic which is a about 1 meter I think. Any Ideas? Do you think that after making this transition one needs to reset the Crystal Sky or restore factory defaults maybe.
 

mdenhartog

New Member
Joined
Sep 14, 2020
Messages
4
Reaction score
2
Age
40
Location
Florida
Thank you for your thoughts.

So far we are trying the HD settings and switching from Full Auto to the 5g band and selecting an specific channel to see if that clears it up. I should have thought of that earlier.
 

Thomas B

Moderator
Staff Member
Premium Pilot
Joined
Jan 25, 2019
Messages
12,166
Reaction score
15,231
Location
Gilbert, Arizona
Thank you for your thoughts.

So far we are trying the HD settings and switching from Full Auto to the 5g band and selecting an specific channel to see if that clears it up. I should have thought of that earlier.
I would contact DJI. I have been flying my M2P mostly using my CS (due to the 7.85” screen) for almost 2 years and have never experienced a noticeable lag in video. I archive to an SD card in the drone. Maybe if too much data must be sent to the CS the drone’s video lags. Don’t know for sure, but it’s a thought. This well is over a thousand flights and flying up to 100 minutes in a day.
 

lannes

Well-Known Member
Joined
Jul 27, 2017
Messages
2,894
Reaction score
1,890
Location
Australia
Thank you for your thoughts.

So far we are trying the HD settings and switching from Full Auto to the 5g band and selecting an specific channel to see if that clears it up. I should have thought of that earlier.
What version of DJI Go4 are you using, the 4.3.16 that is standard on the CS or did you side load a newer version like 4.3.37 ?