DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

iPhone 6s not connecting to controller

trphoto

New Member
Joined
Jan 4, 2018
Messages
3
Reactions
0
Age
68
I recently upgraded the DJI Go 4 app on my iphone 6S (running 10.3.3), and now it will not connect to the controller, or when it does, it will disconnect randomly every few seconds. I have made sure all software is up to date on Mavic and controller, have deleted and reinstalled the app on iphone, but it still has problems connecting. I connected the controller to my ipad with no problems. This just happened after months of happy flying. I have searched online without success. Not sure if this has been brought up here, looked but couldn't find anything. Thanks for any suggestions!
 
Does it let you go into the flight screen? If so, check the status by clicking the top bar on the phone to see what it says.
 

Attachments

  • ACF97A86-B3DB-47B1-8B89-84F4C8DAC813.png
    ACF97A86-B3DB-47B1-8B89-84F4C8DAC813.png
    358.2 KB · Views: 15
No, it just shows disconnected in the top bar. Will not go to flight screen.
 
Be sure to check that the cable is connected properly on both sides. I’ve had this issue once, but just turned everything off then back on and it worked.
 
  • Like
Reactions: dodgedis
Checked all cables. As I mentioned in the post, it works fine with the ipad.
 
Had this same issue. Turns out it was the cable. For whatever reason is stopped liking my older 3rd party cable. I had to use the approved apple cable to get it to work again.
 
Just an update for anyone who runs into the issue with their iPhone not connecting to the Mavic Pro RC/AC with either cable into either port in the remote.
I had just experienced this issue after many flying sessions with no problems connecting my iPhone 6S Plus to my Mavic Pro, suddenly, it would no longer connect to either port of the R/C. Tried all of the suggestions I could find, using different charge cords (I have several) and both ports, startup sequences, updating the firmware, IOS on the phone, etc. Nothing was working. I COULD connect to my iPad with no problem, and I COULD connect to the Aircraft using wifi with my iPhone.
What I did notice though as I was trying every charge cord I could find was that some of the cords would not even connect to my phone. I had this problem a year or so back, and solved it by cleaning out the charge port. This time, cleaning the port became a little more challenging, as I used a plastic dental pick and poked inside the port trying to dig out any debris, lint, etc. It took me several tries, eventually, I took a tissue and packed it into the port gently a few times with the dental pick and then blew the port out with some compressed air. Once I got the port completely clean and working with all of my charge cords again, I connected phone up to the Mavic R/C as normal and everything is up and working again. So long story short, if you carry your phone around in your pocket regularly as I do, and you run into connection issues, try to do a thorough cleaning of the charge port. This may just solve the issue for you.
 

DJI Drone Deals

New Threads

Forum statistics

Threads
132,202
Messages
1,570,816
Members
160,955
Latest member
VKTrendz