DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Mavic Mini Power System Error - Seeking Solutions

  • Thread starter Deleted member 161691
  • Start date
D

Deleted member 161691

Guest
Hey there, fellow Mavic pilots!

Recently, I bought a used Mavic Mini, and it came with an extra drone of the same model. Unfortunately, the additional drone had a broken back right arm, a non-functional motor, and a damaged gimbal. However, we managed to fix the gimbal, and now it serves its purpose as a battery charger.

Inside my primary Mavic Mini, I stumbled upon an unusual issue. It seems that there's some sort of mysterious debris lingering inside the drone. I'll attach a picture so you can see exactly what I'm talking about.

To make matters worse, I've been dealing with a persistent "Power System Hardware Error" notification that keeps popping up. I've been searching through various online forums and articles in hopes of finding a solution. I've tried restarting the drone and cleaning every visible part meticulously, hoping to put an end to this error. Unfortunately, my attempts didn't yield any positive results.

Feeling a bit desperate, I decided to conduct a little experiment. I swapped all the arms from the "healthy" drone to the broken one. To my surprise, the power system error vanished! This led me to believe that I had found the fix. I even managed to fly it indoors a couple of times, thinking I had successfully resolved the issue. However, my excitement was short-lived.

Just the other day, I was all set to take the drone out for some outdoor flying fun, only to realize that I had forgotten to insert my SD card. I promptly powered off the drone, grabbed my SD card, and eagerly inserted it. However, when I powered the drone back on, that same power system hardware error reappeared.

As if that weren't enough, I also noticed two new photo folders on my SD card. One folder contains photos with numbers below 1000, while the other starts fresh from one and keeps counting up. Now, I don't think this is the root cause, but it's worth mentioning. It's the only thing that seems different. Additionally, I tried switching and formatting different SD cards, but I had no luck at all.

Has anyone else encountered a similar issue with the power system error? Do any of you have insights into what might be causing it?

Thanks a bunch for lending a hand as I navigate through this puzzling situation!
 

Attachments

  • IMG_20230624_204842.jpg
    IMG_20230624_204842.jpg
    13.5 KB · Views: 25
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,998
Messages
1,548,293
Members
159,056
Latest member
ksunglieng