DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

MPP Disconnect and Downlink Restored Error?

Marian

Member
Joined
Mar 5, 2018
Messages
6
Reactions
0
Age
37
Hi all,

Long time lurker first time poster. I am coming from a Phantom 2 and recently (beginning February) purchased a Mavic Pro Platinum. I am very happy so far and everything went well.

However, during a small flight yesterday (2018.03.04) which was no longer than 7 minutes my AC seemed to be disconnected a good few times. Looking at the flight log there is no "error message" to be seen. However, you can see the message downlink restored appearing for 15 times.

If I remember correctly, there was an onscreen message (on the phone (Samsung Note 8), upper left corner) mentioning "disconnected" or something similar, but I was still able to control the AC (AC screen all normal) with my RC and brought it into my direction to land it. During this process, the message (on my phone) kept on disappearing and appearing over and over again but yet, I was able to control the AC. I just didn't have any video link. (just a grey screen). I always fly LOS so I was able to bring it back.

However, at minute 5:10 (on the log) it happened again, only that this time the RC screen (not the phone) stated: "reconnecting". At this stage, I was not able to control the AC any longer and it went into RTH mode as you can see from the log. This maneuver lasted for around 11 seconds until the RC was connected to the AC again and I was able to gain control.
I only had one previous quick flight before so the RC's battery was at 80% during this exact flight. The AC had a full and new battery.

Before take off I have updated my home point, I've checked the compass to see if there was any interference (normal pre-flight check) but everything was just fine. From the logs, I am unable to see any strange behavior so I am wondering what could have caused this issue? I personally was also free from any kind of metal, bracelet, wallet, watch etc.

Other than that, I have not gotten any other onscreen messages mentioning any interference or whatsoever. I am also on the latest FW on every device.

Feel free to have a look at the flight log here --> click me

I would be very thankful for any kind of help or thoughts on this.

Thanks.
 
Anyone any thoughts on this? Any help is appreciated.

Thank you.
 
Hi all,

Does no one have an idea or thought on the above? I have a trip coming up tomorrow wanting to fly the drone without any issues and was hoping for some help.

Thanks.
 
Have you tried re-installing the Go App?
Stranger things happened after an update of Go that turned out to be a flawed install. If that doesn't work, reinstall the firmware, preferably through the (latest downloadable) assistant software. I'm curious if that does the trick, good chance though..
 
  • Like
Reactions: Marian
Have you tried re-installing the Go App?
Stranger things happened after an update of Go that turned out to be a flawed install. If that doesn't work, reinstall the firmware, preferably through the (latest downloadable) assistant software. I'm curious if that does the trick, good chance though..

Thanks a lot for that. No, I haven't tried to reinstall anything. The weird thing for me is, I was flying with the same and latest FW since February and it all went well.
The same day of the issue, the flight before was perfectly fine as well. Just on the last flight with nothing changed at all, expect the battery for the AC, it started to disconnect.

The reinstallation of the Go App might help for the disconnects from the phone, but I am uncertain if it helps for the disconnect from the RC to the AC. A firmware reinstall maybe.
 
I'd suggest to try using a fresh new usb cable to connect the RC to the phone
 
  • Like
Reactions: Marian
Hope it helps, it certainly did help me with similar problem, I lost the video feed the phone disconnected, but the RC remained connected, so I RTH, all went well, on the second battery the Phone would no longer get a connection, it turned out to be a USB C adapter, I used a new USB cable I always carry with me for emergencies and it worked fine, didn't get a single disconnection from then on.
 
  • Like
Reactions: Marian
Hope it helps, it certainly did help me with similar problem, I lost the video feed the phone disconnected, but the RC remained connected, so I RTH, all went well, on the second battery the Phone would no longer get a connection, it turned out to be a USB C adapter, I used a new USB cable I always carry with me for emergencies and it worked fine, didn't get a single disconnection from then on.

Thank you. The only weird thing for me was that after I got the video-feed back (Phone connected again to the RC) the RC then started to lose connection to the AC and showed "connecting".

This for me seems to be somehow unrelated to the USB cable.
 
One year later... never had this problem until today. Went for a quick afternoon flight, same route I've flown probably 20 times, line of sight.

The RC never lost connection with the Mavic Pro, but the iPad mini 4's disconnected from the drone many times. Dropping video connection is disheartening, but luckily I could see the MP. If I never lost control of the MP via the RC then this must be a USB-B to Lightning cable error, correct? The cable was cheap from Amazon, and the iPad mini 4 (despite it's "age") is very new, bought it on sale 4 months ago and only use it for flying.

Here's my log: DJI Flight Log Viewer - PhantomHelp.com

Gizmo - did you find a solution?

Thanks,
WTW
 
As you’ve found, you can fly your Mavic without the iPad, it is only repeating and enhancing information that is available from the RC and giving you the visual from the camera. Perhaps you pointed to the problem when you said it was a cheap cable. Maybe something a little better quality next time?
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,082
Messages
1,549,099
Members
159,134
Latest member
kmecaronique