DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

No crash or flyaway here, but a close call

Kuiper Denizen

Well-Known Member
Joined
Mar 30, 2023
Messages
50
Reactions
31
Age
76
Location
Virginia
What happened here? Some input, please.

Two weeks ago I was flying over my wooded property looking for a landmark. My gimbal was about 80 degrees down, and my Mavic 2 Zoom was down the ridge I launched on at 673 ft. away and 71 ft. above my launch site, maybe another 100 ft. above its current position.

Everything was functioning normally, with a few alerts I’ll go over later.

I looked away from my iPad screen momentarily to check my notes on the distance to the landmark.

When I looked back at my video feed the picture was frozen. I’m not sure of the exact order of my responses, but I’m pretty sure my immediate action was to try to move my camera back to zero degrees. The screen remained frozen.

Believing the problem being a loss of signal, I think my next action was to climb to a higher elevation. The screen remained frozen.

Fortunately, when I attempted a yaw, I saw out of the corner of my eye on the inset (at bottom right of the iPad screen) the movement of the drone icon. It was responding to the sticks.

I was able to bring it back to home point and land it, although with the screen still frozen I had to carefully line the drone up with the pad. When I tried to land it manually the drone did not pause for a “look-see,” came down hard, and started back up. I immediately killed it with the sticks-to-inside-bottom maneuver.

After restarting it with a fresh battery all functionality returned, although I haven’t tried to fly any distance.

I realized that it was time to install AirData and reviewing it, along with the flight recorded on both my iPad and separate S.D. card and the flight information on the DJI Go 4 app, I learned the following.

My iPad had made three separate recordings, one up to the point of the freeze (11:55), a second with the screen frozen and me uttering, “What’s going on here?” (0:03), and a third of the drone on the landing pad, gimbal still down (0:07).

The S.D. card made one continuous recording of 15:46. The freeze seemed to start about 12:31. There were eleven freezes on the return trip lasting for 0:19 to 0:46. There was no motion in any of them.

The DJI Go 4 Flight Record shows 15:00 of flight time. There is nothing indicating any problems. At 9:56 there was a “Switched to IMU backup” followed immediately at 9:57 by a “Navigation System Redundancy Switch” notification. The freeze seems to have occurred from 11:03 to 11:14 when the control sticks seemed to be functioning and returned the drone to landing. The gimbal dial was ineffective and didn’t function until after a restart.

It did seem to me that sometime before the freeze there was a notification of a battery problem, but it was too quick for me to read, and it didn’t show on the flight record or AirData.

AirData also didn’t show anything awry. It displays the Tip for the “Switch to Backup IMU” at 9:56 and the Warning of the “Navigation System Redundancy Switch” at 9:57. The batteries and compass had no issues. The Sensors had 30 checks at 100% , 11-16 g.p.s satellites, and a green colored route designating “excellent.” There were two “Minor Signal Errors, one at the start with a “10.7” and one at 11:30 as a “1.9”, whatever those mean. Control seemed okay and Rudder only showed minor delays.

The only issue on AirData was that the “Kp” was at 5.33, indicating that Solar activity was at a “storm” level capable of some interference.

The only other consideration here is that the drone did get jarred before flight while in its hard case, but everything seemed okay in pre-flight.

Now, if there is anyone out there who is still awake and interested enough to make a suggestion that could be helpful or at least enlightening, I’d appreciate your input.

Needless to say, I’m a little snakebit right now.

Thanks for getting this far.
 
Follow the instructions here:


And post the link for forum experts to review. There is a wealth of information in the flight logs that will most likely point to the issue.
 
What model of controller are you using? Check the back of the controller for the model.
If you are using an RC1A then connect the ipad to a computer and have a look to see if there are any .DAT logs in the folder MCDatFlightRecords. If so the airdata site will list a DAT number in the notifications near the start of the flight, look for a DAT containing that number which has a time stamp that slightly preceeds the time stamp of the .txt flight log. Upload that DAT to a file hosting site, make the page public and post the web address here.
If the controller is an RC1B then there is unlikely to be a DAT. on the screen device.

THe DAT on the drone is of no use to anyone but DJI.
 
Sounds odd. Almost like a OS glitch.
My only suggestion based on other info about what happens when the SD card in aircraft goes bad is try a new SD card.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
126,909
Messages
1,515,130
Members
156,324
Latest member
astropapa