Get the most from your Mavic
Join thousands of Mavic owners helping each other
Join Us Now

Problem connecting RC with DJI Go 4 / Litchi

tlicht

Member
Joined
Dec 8, 2018
Messages
5
Reaction score
6
Location
Sweden
Hi, I am new here and also a relatively new pilot.
My problem is the usb connection between the RC and my phone (Moto X Force). Actually the connection between the RC and DJI GO 4 or Litchi is not etabilished. The USB-connection as such seems to be OK since the phone starts charging when I connect it to the RC if the RC is turned on.
I live in the countryside in Sweden. No problems at home (outdoors)- connection always swift and good both with and without the WiFi enabled on my phone. If I go a mile away and try fly from there most of the time (like 99%) the MA and the RC connects fine but the connection is not estabilished between the RC and DJI Go 4 or Litchi. And yes, only one of DJI Go 4 / Litchi is running. I usually close both down before I connect the USB.
I have tried every imaginable order of starting/connecting the devices with the same poor results.
When it works (at home) I get the choice of which app (DJI Go 4 or Litchi) will connect to the USB. Not when I try to start a mile away.
I can even program a flight (Litchi) and successfully execute it from my home to areas where I cannot get the RC to connect with the app.
Getting bald scratching my head....
 

pvs

Well-Known Member
Joined
Dec 18, 2018
Messages
110
Reaction score
44
Age
64
Location
WNC
Hi, I am new here and also a relatively new pilot.
My problem is the usb connection between the RC and my phone (Moto X Force). Actually the connection between the RC and DJI GO 4 or Litchi is not etabilished. The USB-connection as such seems to be OK since the phone starts charging when I connect it to the RC if the RC is turned on.
I live in the countryside in Sweden. No problems at home (outdoors)- connection always swift and good both with and without the WiFi enabled on my phone. If I go a mile away and try fly from there most of the time (like 99%) the MA and the RC connects fine but the connection is not estabilished between the RC and DJI Go 4 or Litchi. And yes, only one of DJI Go 4 / Litchi is running. I usually close both down before I connect the USB.
I have tried every imaginable order of starting/connecting the devices with the same poor results.
When it works (at home) I get the choice of which app (DJI Go 4 or Litchi) will connect to the USB. Not when I try to start a mile away.
I can even program a flight (Litchi) and successfully execute it from my home to areas where I cannot get the RC to connect with the app.
Getting bald scratching my head....
This issue is probably your cable. The one you're using is a charging cable. You need one that supports data.
 

tlicht

Member
Joined
Dec 8, 2018
Messages
5
Reaction score
6
Location
Sweden
Thank you for interesting suggestion. Then it is actually quite strange that the same usb cable works OK when I am outside my house. To be certain I just tested the cable - it is a data cable since I could use it to communicate with ESP8266 modules.
 

tlicht

Member
Joined
Dec 8, 2018
Messages
5
Reaction score
6
Location
Sweden
Problem partially solved. I found my previous phone - an LG G Flex 2 - and that phone connects easily to the RC also at locations where the Moto X Force had problem... So now I have a screen/phone for exclusive use with the MA.
 
  • Like
Reactions: pvs

New Threads

Forum statistics

Threads
80,173
Messages
928,381
Members
108,432
Latest member
DaOne559