DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Virtual Litchi Mission sending to Google Earth is OK on desktop, but gives error on laptop

timsharp03

Member
Joined
Jul 14, 2022
Messages
17
Reactions
15
Age
69
Location
North Yorkshire UK
I've been setting up waypoint Litchi missions on my desktop computer for a while now and they all go well. I have just bought a small laptop (Windows 10 i5) to take on holidays so I can edit and create new missions while away.

Problem is that on some missions, when I send them to Google Earth from the laptop, I get an error - "Unhandled exception has occurred in your application". I've attached screenshots of the same mission on the laptop with error and on the desktop with no errors. The only real difference in the computers is that the desktop runs Windows 8.1 and the laptop runs Windows 10 .

Can anyone help identify what the problem might be please?
screen grab bergen mission error.jpg

screen grab bergen mission ok.jpg
 
VLM is not a Litchi product. Questions should be posted to the main Virtual Litchi Mission thread that Namirda started. However, comparing the two instances and looking at the trace back, it seems there might be a problem at waypoints 16 and 17. I would remove one or both of them. You appear to have more waypoints than necessary.
 
Hi Tim,

That looks very much like a bug - strange that it has not surfaced before.

Can you please post a link to the mission which gives problems and I will take a look into it.

Make sure you have removed the 'private' flag.

N
 
Hi. Thanks very much for your replies.

I don't know how to post a link to the mission - when I click the link button in My Missions, all it does is open a new window with the mission in it - not sure how to get the link from that.

I have removed the 'private' flag on it, but don't know if that makes it show up in the Discover section.

I tried to attach the downloaded mission file but it is not an allowable file type, so I downloaded a .csv and saved it as a .txt file - not sure if this is useable - please let me know if there is a way for me to send a link.

I did notice that if I created a new mission without any POI's, that it gave the same error messages on the laptop but not on my desktop computer. The Bergen mission does have POI's, but I perhaps didn't add them until I'd added waypoints - maybe that's something to do with it?
 

Attachments

  • Bergen harbour from park.txt
    4.5 KB · Views: 2
I don't know how to post a link to the mission - when I click the link button in My Missions, all it does is open a new window with the mission in it - not sure how to get the link from that.
All you have to do is copy the URL from your browser window and paste it here.
 
Oh, I didn't realise - I was in Virtual Litchi Mission which doesn't show a URL. URL from Litchi Mission Hub below.
Hi Tim,

I think the problem is that for WP1 and WP2 you have set Gimbal Pitch to "Focus POI" and yet have set POI to "None". There is nothing inherently wrong with that combination - I just didn't consider it a possibility and so didn't handle it properly in the code.

Please set the Gimbal Pitch for WP1 and WP2 to "Interpolate" and let me know how that goes. If it solves the problem then I will upload a fix.

This bug only crept into the code in 2.7.2 - perhaps you are running an earlier version on your desktop?

N
 
Last edited:
Wow, I'm very impressed. That is exactly it - I was using 2.7.1 on my desktop and 2.7.2 on my laptop. I did the changes as you said and problem solved. I never fully understand what Interpolate actually does so sometimes I click on focus POI to set the gimbal angle, then interpolate as it then keeps it. On those two I obviously didn't do it properly. Thanks for a wonderful application - it makes drone flight planning so much more enjoyable.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
131,012
Messages
1,558,910
Members
159,995
Latest member
KenArlidge