Get more from your Mavic
The largest Mavic community in the world
Join Us Now

White cloud

Geo

Well-Known Member
Joined
Nov 24, 2016
Messages
148
Reactions
64
Age
70
Since the latest update I've been getting a white cloud that comes over my screen. Sometimes it goes away, sometimes not. The videos record perfectly. It must be something wrong with the transmission of the picture to my remote. Any thoughts? In addition since the update my battery pct remaining is no longer showing.
 

Geo

Well-Known Member
Joined
Nov 24, 2016
Messages
148
Reactions
64
Age
70
It's asking to update again. I'm doing it and will report if it fixes it, yea right.
 

Geo

Well-Known Member
Joined
Nov 24, 2016
Messages
148
Reactions
64
Age
70
I also noticed the bottom of my mavic is getting too hot to touch after just five minutes of flight. There must be something wrong interior wise.
 

Geo

Well-Known Member
Joined
Nov 24, 2016
Messages
148
Reactions
64
Age
70
No, I’ve tried it in all light conditions and same problem. I will try your suggestion though and see if it helps.
 

Geo

Well-Known Member
Joined
Nov 24, 2016
Messages
148
Reactions
64
Age
70
I see another poster with the same problem now. Wonder if this is a just developing problem? Don't ask me why?
 

lisadoc

Well-Known Member
Joined
May 29, 2017
Messages
1,020
Reactions
687
Since the latest update I've been getting a white cloud that comes over my screen. Sometimes it goes away, sometimes not. The videos record perfectly. It must be something wrong with the transmission of the picture to my remote. Any thoughts? In addition since the update my battery pct remaining is no longer showing.

Update of the FW or the Go app?

And I can see the battery pct remaining on your screen right where it normally is.

Screenshot_20180626-162256.jpg
 

Kilrah

Well-Known Member
Joined
Nov 12, 2016
Messages
6,237
Solutions
1
Reactions
3,443
Age
38
Location
Switzerland
On Android phones you can change the default font, which will affect everything on the system.
 

Geo

Well-Known Member
Joined
Nov 24, 2016
Messages
148
Reactions
64
Age
70
Ok, confirmed that this is a software glitch on Android only phones. Your only fix is to go back to .16 from .20 . That does work.
 
Lycus Tech Mavic Air 2 Case

New Threads

Forum statistics

Threads
104,024
Messages
1,205,022
Members
132,721
Latest member
FlyBoy44