Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

"if ain't broke don't fix it"?

Joined
Oct 29, 2017
Messages
1
Likes
1
Age
38
#1
so a while ago i bought the bird with with firmware .700 and installed iPhone app 4.1.7

i did upgrade the app on a second phone and afer upgrade the autoedit movies are crap, they play with stuttering. both phones are iphone se.

goggles ordered a couple of days ago. will they work with above versions?
is there any serious bug or feature as reason to upgrade any of these versions?
I'd like to stick with "if ain't broke don't fix it" motto.
 
Likes: Kalvik

Kalvik

Well-Known Member
Joined
Apr 19, 2017
Messages
52
Likes
39
Location
Kugluktuk
#3
That's my mantra. I'm still on whatever software/firmware version that was installed when I bought my Mavic a year ago. Flies like a dream!
 

Robert Mitchell

Well-Known Member
Joined
Oct 27, 2016
Messages
1,272
Likes
984
Age
62
#5
That's my mantra. I'm still on whatever software/firmware version that was installed when I bought my Mavic a year ago. Flies like a dream!
And yet I bit the bullet, after hanging on for months, and fully upgraded. Mine also flies like a dream with full functionality including goggles.
No issues, no glitches, range tested to over a mile, so far, and no calibrations including compass or IMU ever, across the entire eastern half of the US.
In the name of full disclosure, the only thing I changed was going to IOS since I bought the Mavic almost a year ago.
Trust me, I have no criticism toward staying where you are if happy, it just limits the additional functionally going forward.
You don’t need or want the new features or functions, by all means stay where you are.
 
Last edited:

Andrew F

Well-Known Member
Joined
Nov 24, 2016
Messages
709
Likes
312
Age
58
#6
You are already past the sweet spot with regards to operating systems. Once it got to 7, the entire methodology for testing whether you were or were not in a no-fly zone changed. From my perspective, there would be no reason for you to not continue upgrading if you felt like it. I am on a much older version of the operating system, and I will never upgrade no matter how cool the future features may seem.

so a while ago i bought the bird with with firmware .700 and installed iPhone app 4.1.7

i did upgrade the app on a second phone and afer upgrade the autoedit movies are crap, they play with stuttering. both phones are iphone se.

goggles ordered a couple of days ago. will they work with above versions?
is there any serious bug or feature as reason to upgrade any of these versions?
I'd like to stick with "if ain't broke don't fix it" motto.
 
Likes: Flycaster

Pathogen

Well-Known Member
Joined
Jun 8, 2017
Messages
330
Likes
231
Age
46
#8
Unfortunately the Goggles head tracking wont work on Mavic with 0700 firmware if the Goggles aren't also 0700 firmware. I rolled back the Mavic to 0400 which makes pitch head tracking work great, but breaks the yaw head tracking, which is actually great since I only wanted pitch head tracking in the first place.
 

lisadoc

Well-Known Member
Joined
May 29, 2017
Messages
1,020
Likes
665
#9
Unfortunately the Goggles head tracking wont work on Mavic with 0700 firmware if the Goggles aren't also 0700 firmware.
Why is that so hard (to have the Goggles on .700 too)? You make it sound like it's an issue. Is there something I'm missing?
 

Pathogen

Well-Known Member
Joined
Jun 8, 2017
Messages
330
Likes
231
Age
46
#10
Why is that so hard (to have the Goggles on .700 too)? You make it sound like it's an issue. Is there something I'm missing?
well if the mavic in on 0700 then the goggles have to be on 0700 to use head tracking. un fortunately the head tracking on 0700 doesn't have the new damping options and some people might not like the jerkiness of the head tracking. also others don't like the fact that there are other features on newer goggles, like the remote control signal strength meter, and probably other things I am not remembering.
 

New Threads

Forum statistics

Threads
47,456
Messages
554,945
Members
70,214
Latest member
wnd50