DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

No video feed to phone and says "Aircraft Disconnected"

safa

Member
Joined
Apr 25, 2017
Messages
12
Reactions
3
Age
34
Evening all,first time drone owner and im having some drama.
first few flights where fine no dramas at all.But now i have No Video feed to my phone,and i have several different messages that have displayed

1:Aircraft Disconnected
2:Radio channel quality - poor
3:Gimble status - Disconnected

What i have done to try and fix it:
-Use an alternative usb cable to the centre of the controller ensuring the left one is disconnected
-Restart all devices,phone, controller,drone
-Delete the DJI GO 4 app several times
- Tried my phone in flight mode
-Ensured the small left hand side usb cable was in correctly
- Removing the memory card
- Putting it on wifi mode
it cant be a signal issue as i flew it in the same location i later had trouble with.

My phone is a Honor 8 (same specs as a samsung galaxy s7) and worked fine the first few flights.
No of the kit has been dropped/crashed or exposed to extreme temperatures

Im at a loss as to what i can do,and from what i hear DJI dont have the best customer service.
 
  • Like
Reactions: tema
What message are you getting on your controller? Can you take a picture?

Can you try a different device? If it still does it, you might need to rebind the controller to aircraft.

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
It comes up with ATTI MODE and READY TO GO, i dont have another device unfortunately

Just tried re linking, still no feed
 
Sounds like a device problem because the controller is binding to the aircraft.

You must know someone whose device you can borrow to test, preferably a Samsung or Apple device.
 
I can borrow one tomorrow but i don't understand how it can work and then not and the work and then not etc if it's the device ..Surely it just wouldn't work?
These are some screen shots i took Screenshot_20170422-195654.png Screenshot_20170422-185552.png Screenshot_20170422-185655.png Screenshot_20170422-185713.png Screenshot_20170422-195654.png Screenshot_20170422-195654.png Screenshot_20170422-185552.png Screenshot_20170422-185655.png Screenshot_20170422-185713.png Screenshot_20170422-195654.png Screenshot_20170422-185552.png
 
I'll attach pics,the rear light is flashing but not fast and is going from green to red,but earlier when my phone was connected I'm sure it just did green
IMG_20170425_235243.jpg IMG_20170425_235221.jpg IMG_20170425_235219.jpg
 
A similar problem brought me here. New drone arrived Friday, worked fine last night, today I can fly for a few seconds and then it disconnects. In addition to losing video feed, the remote stops working and I cannot control the drone. The drone performs an automatic RTH as if I had turned the controller off. Turning the controller off and back on allows me to regain control and interrupt the RTH.

It's almost as if the remote itself is locking up. Attempted to factory reset the remote and the process failed according to the DJI assistant program. Maybe bad remote?
 
If 6.00 I would try going back to 4.00 just to check,
 
I got the message while flying, remote tried to reconnect but not before it drifted into a tree.
 
Remote was on .500, I rolled it back to .400 and it hasn't exhibited the same symptoms again -yet-. I'd heard .400 was the version to stick to and this stuff is probably why.
 
im confused .. how do you roll back the firmware? i just downloaded the latest app
 
In app 3 dots right upper corner hold 3 sec. It will come up with firmware options.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,238
Messages
1,571,255
Members
160,985
Latest member
Jonny2Skis