DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Remote Control Mavic - No gimbal control - Bug or feauture?

paulbeumer

Member
Joined
Jan 31, 2017
Messages
17
Reactions
6
Location
Amsterdam
Hi,
Beginner with question for DJI experts.

Today i was flying in beginner mode near nice big patch of soft green grass with only a few trees. Windspeed 20km/h wind...with some gusts inbetween..so i learned a lot today :- (amazing how steady it flies. During my second battery my iphone 6s battery informed me that it had 20% left. So i decided to land the drone, unplug the iphone and try to fly with only the Remote control. Staying low and nearby. The RC stayed in beginner mode with GPS. When flying i noticed that when using to gimbal tilt control the gimbal didn't reacted..(i anticipated that anyhow the footage would be quit raw, but just for the experiment i wanted to control the gimbal)

So does anyone know if it's a feature that the gimbal control wheel doesn't work when flying with RC only?

Greetings from Amsterdam
 
  • Like
Reactions: Rnl and eric18
Could be disabled in beginner mode, try it out of that mode on the bench.

If you want your batteries to live longer i would try not to go below 20%.
 
Could be disabled in beginner mode, try it out of that mode on the bench.

If you want your batteries to live longer i would try not to go below 20%.


NickB thx for the reply. I'll try different configurations and give an update..
 
RC version 01.03.500
Update
Did some RC-only testing on the bench.

1. Started with RC Only. (On startup. No mentioning of beginner mode in RC)
Following functions on RC seem to work.
-Video record button (RED LED turned off when start recording and on when finished)
-Photo button (LED same as above so i asume it was working)
-Gimbal wheel works Gimbal goes up and down
-ISo wheel seem to work to. (double checked.. in step 2 image was completely underexposed)

The 5D button that i've configured with gimbal up-down doesn't react. also C1 and C2 button did not react

2. Put in Iphone (dji go4 active) without switching off Mavic or RC
All setting as configured work...

3. Before taking out iphone i put system in beginner mode.
took out iphone.
-sytem stayed in beginner- mode
-c1 +c2 button did not react anymore
-5d button did not react any more

4.Switched of RC leaving Mavic powered-on. waited 3sec.
RC started up in beginner mode
Same result as in 1.


5. Last one switching off all. Waiting 15 sec before restart
Switchin on Mavic and RC Only.
Same result as in 4.

Anyway no flying related critical functions can be mapped either C1 and C2 or 5D button. In a way it makes sense that they don't function if you have no phone connected.
Why the gimbal didn't work in my posting of 1st feb... i have no clue.
 
  • Like
Reactions: YelloJacketStatus
I have a similar problem with my brand new Mavic. Gimbal randomly disconnects with or without using my iPhone. Image continues transmiting but I'cant control the gimbal and change camera settings and even format SD card!!! I tried other firmwares but no success.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,862
Messages
1,557,249
Members
159,888
Latest member
TD22