Get more from your Mavic
The largest Mavic community in the world
Join Us Now

First flight(s), problems and solving them

MavericPro

New Member
Joined
Sep 21, 2017
Messages
2
Reaction score
5
Age
41
Hi, and pardon my french. English is not my native language, but I hope this makes some sense...
I'm just writing my story here, I hope it helps someone who might have same issues.

I bought my MP fly more combo last thursday and I was anxious to get it in the air. Before buying MP, I had been reading tons of posts from forums and looked videos from Youtube. But I never thought getting started could be this difficult. Mavic Pro is my first drone and mobile device I'm using with it is Sony Xperia Z5. And I'm not a tech guy.

When I got home, I of course charged batteries and rc, read manual etc. Then I connected my mobile device, rc and mp and updated the firmware. Next day I went to my summer cabin and during the weekend had the first flights, many of them. Beforehand I was thinking that I might have some problems, because I was on an island and it's basically solid rock and stones, not much soil on them. So I powered up mp, rc and DJI GO4 when I got there. I took off and everything seemed to be fine. Until I took some distance. And that distance was about five meters. Compass error, exit p-gps mode, atti mode. And rc showed "system error check app". Every time. I tried four different locations and same thing. Also two times I got notifications "disconnected" and immediately after that "aircraft disconnected". And it meant that it wasn't just my phone disconnected, it was also rc disconnected from aircraft. Disconnection lasted about 30-40 seconds until rc worked again. And between first and second time this happened, I had my rc re-linked with mp. Gladly I didn't crash my mp. There were 18-21 satellites all the time so I was confused about the compass errors.

Same time with all these attempts, I also had a problem with my phone. It was connected to rc with short micro usb cable to the side of rc. It kept giving notifications, what would I like to do when connected to usb-device. Charging, file transfer or midi. I got pretty frustrated. USB debugging mode didn't help at all. Few times there was a notice about strong magnetic interference.

At some point I changed the micro usb cable from the side of rc to the normal usb cable at the bottom of rc. Now my phone asks that charge/file transfer/midi question just once, when powering up my rc.

Then I remembered that there is a radio/tv tower at mainland. I read that mp shouldn't be used near these, and my distance to this tower was about 13 kilometers. But there was practically just open water between me and the tower, so I think it might have interfered my rc -mp connection. Tower is 320 meters high from the ground/sea level.

I tried my mp dozens of times, and it always went to atti mode after distance was 5 - 20 meters. Always. I thought maybe it was broken. IMU and compass status were fine (green), every time. Compass error also showed up when hovering but rotating 360 degrees.

After weekend I got back home and back to my laptop. I loaded DJI Assistant 2 and connected my mp and rc to my laptop. I noticed that mp had the latest firmware, but rc didn't. I thought it was updated but afterall, it wasn't. So I updated my rc.

Next I went to a nearby park for a new flight. Everything seemed to be ok, no magnetic interference or any other notifications, until I took some distance. About 15 meters. Compass error, exit-p-gps mode, atti mode. System error, check app. All this again. I was desperate.

Then I went back inside. I hadn't calibrated my mp IMU or compass, because I had read that it should be done only if app requires it, and all sensors were excellent. Anyway, I decided to do both. So I calibrated IMU, went to the park and calibrated compass. And voila. It was perfect. No errors at all. I think it was my 79th or 80th take off and for the first time everything was fine. Now I have couple flights without any kind of problems, few good test photos also.

Conclusion: compasses and rc are quite sensitive for any kind of interference. Suggestions, if you have no experience about flying drones and Mavic Pro is your first drone:
- Calibrate IMU and compass in a flat and straight surface and in a surrounding with absolutely no interference.
- Take baby steps. Don't fly far, don't fly high. When your Mavic is in 50 meters altitude with a bit windy conditions and it goes to ATTI mode, the surprise is not pleasant.
- If previous happens, stay calm. If you panic, you crash.
- When updating firmware especially for the first time, do it via DJI Assistant for mp and rc, not via your mobile device connected to rc. Just to be sure.
- Remember pre flight checklists.
- If your mobile device is not listed in compliance list, fly small radius for some time to make sure DJI Go4 don't crash down and get to know how your device works best with rc and mp. I have to power up first my Mavic, then DJI Go4, and then rc. If I turn on rc first and then the app, app won't connect with aircraft.

Long story not short, I hope it helps others. Your Mavic might not be broken even if it seems to be.
 
  • Like
Reactions: fmnsp

Robert Mitchell

Well-Known Member
Joined
Oct 27, 2016
Messages
1,427
Reaction score
1,193
For a beginner you were very cool and didn't loose your head... good qualities which will serve you well going forward.

You were very persistent, and I'm glad things worked out well for you.
 
  • Like
Reactions: fmnsp and Flycaster