Get more from your Mavic
The largest Mavic community in the world
Join Us Now

How to downgrade your App for iPhone / iPad iOS

RAMJET-1

Well-Known Member
Joined
Mar 14, 2017
Messages
63
Reactions
49
Location
Southeast Alabama, USA
Visit site
For those of us that don't like the latest iOS (iPhone/iPad) app update for Go4 and would like to revert back to an older version that you did like better, here is a video with step by step instructions. Last night I was successful reverting from GO4 ver.4.1.0 to ver. 4.0.1 for iOS on my iPad mini 4 following these instructions. Note that I was not having any negative issues with 4.1.0, I just wanted to try this to see if it would work and it did. So for anyone using iOS devices and want to downgrade your app that is giving you problems, here you go.

EDIT: I am not the author of the video. Credit for the video posted goes to Jerry Dotson. Also, the download links that are posted were published by digdat0. All credits should go to these two guys for this helpful information.

You will need to use your PC to perform this process.

First, download and install iTunes 12.3.1 (newer versions will not work). If you have an older version, uninstall it after backing up what you need.

x64 http://eshareload.com/itunes/iTune%20...
x86: http://eshareload.com/itunes/iTunes%2...
WinXP: http://eshareload.com/itunes/iTunes%2...
Mac: http://eshareload.com/itunes/iTunes12...

Install iTunes, then download and install Charles Proxy 3.11.7 from the following page:
https://www.charlesproxy.com/previous...

Version sheet for DJI GO 4 located here:
https://docs.google.com/spreadsheets/...

Here is the video with step by step instructions to follow. Cheers!!


RAMJET-1
 
Last edited:

Robin

Well-Known Member
Joined
Oct 28, 2016
Messages
354
Reactions
137
Visit site
I just keep the old x.ipa file when an update is done, it automatically puts this in the trash.
 

Memphis_Mavic

Well-Known Member
Joined
Oct 12, 2016
Messages
62
Reactions
87
Age
52
Location
Memphis,TN
Visit site
Answer me this please on uploading an app from itunes. If I had the old app on my iPhone 7 and I backed it up to itunes, would I be able to put this version on a new iPad mini that I purchase or would I have to download the new app? I'm not real familiar with how itunes work. Thanks for the help!
 

RAMJET-1

Well-Known Member
Joined
Mar 14, 2017
Messages
63
Reactions
49
Location
Southeast Alabama, USA
Visit site
Answer me this please on uploading an app from itunes. If I had the old app on my iPhone 7 and I backed it up to itunes, would I be able to put this version on a new iPad mini that I purchase or would I have to download the new app? I'm not real familiar with how itunes work. Thanks for the help!

Wish I could answer your question but I've only had my 1st Apple iPad mini 4 for about 3 weeks. Have had Android for 3 years. I would think if the app is synced to your iTunes library you should be able to sync your new iPad and copy to it. That's basically how I downgraded the GO4 app with the exception of using my PC to load the app in my iTunes > My Apps. Give it a whirl, you have nothing to loose.
 
  • Like
Reactions: Memphis_Mavic

flyNfrank

Well-Known Member
Joined
Oct 12, 2016
Messages
599
Reactions
230
Location
INDY, USA
Visit site
I removed the newer version iTunes and installed from the above link. After installing and attempting to open I get the follow message....

The file "iTunes Library.itl" cannot be read because it was created by a newer version of iTunes.

The downloaded version will not start now.
 
Last edited:

flyNfrank

Well-Known Member
Joined
Oct 12, 2016
Messages
599
Reactions
230
Location
INDY, USA
Visit site
I removed the newer version iTunes and installed from the above link. After installing and attempting to open I get the follow message....

The file "iTunes Library.itl" cannot be read because it was created by a newer version of iTunes.

The downloaded version will not start now.

I'm working on this now. Think I have a way around. Going to download Charlie now.
 

RAMJET-1

Well-Known Member
Joined
Mar 14, 2017
Messages
63
Reactions
49
Location
Southeast Alabama, USA
Visit site
I removed the newer version iTunes and installed from the above link. After installing and attempting to open I get the follow message....

The file "iTunes Library.itl" cannot be read because it was created by a newer version of iTunes.

The downloaded version will not start now.


What OS is your PC. Mine is Windows 10 (64 bit) and I didn't have any issues what so ever. But I never had iTunes on my PC prior to this either.
 

bunzik

Well-Known Member
Joined
Jun 21, 2017
Messages
68
Reactions
24
Age
41
Visit site
Can be solved by deleting all iTunes file manually after the removal
There's more files but I forget the place but can easily find by searching *.itl
And delete all the library
And install the older app in program files 86
 
  • Like
Reactions: RAMJET-1

bunzik

Well-Known Member
Joined
Jun 21, 2017
Messages
68
Reactions
24
Age
41
Visit site
Can be solved by deleting all iTunes file manually after the removal
There's more files but I forget the place but can easily find by searching *.itl
And delete all the library
And install the older app in program files 86
 

flyNfrank

Well-Known Member
Joined
Oct 12, 2016
Messages
599
Reactions
230
Location
INDY, USA
Visit site
Please keep us posted on your progress and what issues /


Keep us posted on your progress. Interesting to know what the issue was with iTunes.

I'm currently stuck based on your video. Near the beginning of your video you mention deleting the GO4 app. You do it from a page that shows several apps. My problem is I do not have such page that shows apps at the location your video appears to have them.

What do you suggest?

itunespage.jpg
 
Last edited:

Simon.pl

New Member
Joined
Apr 17, 2017
Messages
4
Reactions
2
Age
43
Visit site
I would say you don't have any apps there because you don't have your phone connected?
I did the downgrade in the following way:
1. Uninstalled the app from the iPhone
2. Uninstalled the iTunes from my MacBookPro and manually deleted the old library finding it through "search" option.
3. Installed the older version of iTunes
4. Followed the steps from the video regarding "how to download the older version"
5. With the version 4.0.7 (in my case) downloaded on my MacBook I have connected my iPhone6s and when the message that I need newer version of iTunes to be able to connect the phone popped up, I have upgraded the iTunes and sync the app to the phone.

The end :)
 
  • Like
Reactions: RAMJET-1

flyNfrank

Well-Known Member
Joined
Oct 12, 2016
Messages
599
Reactions
230
Location
INDY, USA
Visit site
I would say you don't have any apps there because you don't have your phone connected?
I did the downgrade in the following way:
1. Uninstalled the app from the iPhone
2. Uninstalled the iTunes from my MacBookPro and manually deleted the old library finding it through "search" option.
3. Installed the older version of iTunes
4. Followed the steps from the video regarding "how to download the older version"
5. With the version 4.0.7 (in my case) downloaded on my MacBook I have connected my iPhone6s and when the message that I need newer version of iTunes to be able to connect the phone popped up, I have upgraded the iTunes and sync the app to the phone.

The end :)

The only difference in yours and mine is you deleted the GO4 app from your device(iPhone) and I have not.
 

flyNfrank

Well-Known Member
Joined
Oct 12, 2016
Messages
599
Reactions
230
Location
INDY, USA
Visit site
After downloading the DJI GO 4 app from the itunes store, I don't get the edit request from Charles, so I'm unable to proceed. I noticed others have had this same issue with nobody responding back to help them.

What might the issue be?

-Windows 10 (64 bit)
-Firefox browser
 
Last edited:
All E RC Mavic Drones
Lycus Tech Mavic Air 2 Case

New Threads

Forum statistics

Threads
96,979
Messages
1,114,466
Members
124,510
Latest member
Alphacide