DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Repeated iPhone 7 Plus disconnect in Tripod and Gesture modes?

domination

Well-Known Member
Joined
Feb 11, 2017
Messages
88
Reactions
76
Age
55
New to this hobby, have had my Mavic for a little over month. Overall, I am extremely happy with the purchase. However, having dealt with consumer electronics for so long and considering the incredible amount of technology crammed into this Modern Marvel, my "new tech pain threshold" is somewhat high. To boot - today, I was shooting my son and his friend and I wanted to show off how AWESOME this Mavic is in taking pics/vids. I was toggling between "Gesture", "Tripod", "Normal" modes. So, we were having fun with that. Then, they head to trampoline and I wanted to capture some multi-angle shots and video of their flips. Screen would go dark, lose video, then "Disconnect". Unplugged from side connector and plugged back in... Nope... (I've run into this before and sometimes this works)... Restarted Go 4 app - would come on again and then that f**$# dreaded "fade to gray" screen appeared "Disconnected" - lost video and disconnect... This continued 3-4 times, restart Go 4 app, unplug from side, etc... Finally, said F this and went picked up iPad air and connected to bottom USB. Worked perfectly - no issues. however, I also did not toggle between those modes, either. Best I can figure is that I was toggling between "Tripod", "Gesture" and "Normal" modes which may have created some sort of situation to cause this to occur? Possibly FW update? iPhone 7 Plus specific?
 
Last edited:
Dang. My Iphone 7 I was useing when I first got mine. Went out 1800 m and started fading on me. Never thought about it till you brought it up. Had a spare Iphone laying around and started useing it. Iphone 6+. No issues
 
I'm experiencing the same problem with an iPhone 7 plus. Gary screen, disconnection and sadly small crash. Any fix to this problem? Could it be the slider of the connector that prevents the lightening cable to plug in completely in the iPhone?
 
I'm experiencing the same problem with an iPhone 7 plus. Gary screen, disconnection and sadly small crash. Any fix to this problem? Could it be the slider of the connector that prevents the lightening cable to plug in completely in the iPhone?
I haven't had this problem - the disconnect with my iPhone 7 plus - since the past FW update .700. Not sure if that fixed it or not. But no issues to report. The lightning cords, especially non-OEM (generic) can also be quite finicky as well. Work around will be to plug into bottom USB on RC. Just remember to unplug lightning cord from side of RC.
 
I have a 7+ also and have had no issues. I have noticed that you need to make sure the cable end is plugged all the way into the iphone if using the small one that comes with the unit.. Sometimes mine needs a little extra love to get in there ;)
On a side note look closely into the charging port of your phone. I have had issues where lint starts to accumulate in there and some cables have issues with it.
Hope this helps or if not you get things figured out. Keep us posted.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

Forum statistics

Threads
130,931
Messages
1,558,048
Members
159,938
Latest member
mrose