DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Samsung Galaxy issues anyone else?

51 Drones

Well-Known Member
Joined
Mar 6, 2017
Messages
286
Reactions
600
So for about 2 months, I have been having the following issues with DJI Go 4 and my Samsung Galaxy S8+. Anytime I try to toggle some of the settings in under the "gear" icon, they don't work. For example, I toggle the histogram on, then return to main screen, but no histogram. Then I return to the settings and it's toggled off. This happens with several of the other settings as well DJI tech (un)support said try a different device, so tonight I tried my wife's Galaxy S7, and still did the same thing. Could some of you Samsung users check it out and let me know if you are having the same problems? I did just finally order a Ipad Mini 2. Thought I would try IOS for a while.
 
  • Like
Reactions: SpikeSky
I have used a s7, note 5, and the tab a with no issues. I run an older version of Go, .14 I think.
 
I been using my S8+ for 6 months with zero issues, I fly using the latest firmware for both drone and app. Had a disconnecting issue during flight a month or so ago but that turned out to be a faulty lead, my fault for buying cheap there.

The only time my histogram vanishes is if I swap batteries mid session, but that's fixed by flicking the histogram 'off and on' again.
 
Had loads of app crashes with the S7 but since getting my S8 had no issues at all. I have noticed that if you cache to an external SD card, the menu takes slightly longer to appear after clicking the 'dots' icon.
 
Hey brother 51 Drones, sorry can’t help with your Android phone :-( I am a IOS guy and have had no issues with my iPhone 6s. I’ve been told the best matching phone is the iPhone 7plus 128gb or higher. Also the iPad mini 4th Generation wifi / cellular is a good choice. Anyhoo I recon you will be happy with the IOS systems. Looking forward to your next YouTube posting. Cheers my friend Spike
 
  • Like
Reactions: 51 Drones
I tried upgrading with the DJI Assistant, but it says "cannot load firmware list". Does DJI Assistant even work? I've never used it.
 
So for about 2 months, I have been having the following issues with DJI Go 4 and my Samsung Galaxy S8+. Anytime I try to toggle some of the settings in under the "gear" icon, they don't work. For example, I toggle the histogram on, then return to main screen, but no histogram. Then I return to the settings and it's toggled off. This happens with several of the other settings as well DJI tech (un)support said try a different device, so tonight I tried my wife's Galaxy S7, and still did the same thing. Could some of you Samsung users check it out and let me know if you are having the same problems? I did just finally order a Ipad Mini 2. Thought I would try IOS for a while.
I had this problem exactly with my S8 , but it was coupled with a replacement aircraft. Anyway I was instructed to re-set the camera, but it would not! I then re-calibrated the compass out side ..took her for a short spin...then took her inside and re-calibrated the IMU...Bingo! the camera re_set and the histogram etc re-appeared.... I think it may be more to do with the new 300 firmware??
 
I had this problem exactly with my S8 , but it was coupled with a replacement aircraft. Anyway I was instructed to re-set the camera, but it would not! I then re-calibrated the compass out side ..took her for a short spin...then took her inside and re-calibrated the IMU...Bingo! the camera re_set and the histogram etc re-appeared.... I think it may be more to do with the new 300 firmware??
Great, I will try that! Thanks!
 
So for about 2 months, I have been having the following issues with DJI Go 4 and my Samsung Galaxy S8+. Anytime I try to toggle some of the settings in under the "gear" icon, they don't work. For example, I toggle the histogram on, then return to main screen, but no histogram. Then I return to the settings and it's toggled off. This happens with several of the other settings as well DJI tech (un)support said try a different device, so tonight I tried my wife's Galaxy S7, and still did the same thing. Could some of you Samsung users check it out and let me know if you are having the same problems? I did just finally order a Ipad Mini 2. Thought I would try IOS for a while.

I have exactly the same issue :-(

None of the settings above the Grid line of the menu doesn't work, while Grid and everything below works just fine.

Have you fixed the issue on your Galaxy S8? Was it IMU re-calibration? If so, how can it be done?

Thanks in advance!
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,014
Messages
1,548,398
Members
159,070
Latest member
gremmy