Get more from your Mavic
The largest Mavic community in the world
Join Us Now

Samsung S9+ GPS Interference

dizzy11

New Member
Joined
May 14, 2018
Messages
2
Reaction score
0
Age
31
Hi guys,

Have been using DJI Mavic Pro to film parts of sports trainings for about 6 months. Everything was working perfectly until I changed from iPhone 7 to Samsung S9+ about a month ago.

Since changing over, the GPS trackers on some of the players are not being transmitted to their respective receiver. I've attached some specs of the GPS trackers.

It wasn't an issue with the iPhone, so I'm wondering if anyone has any knowledge of what could be causing this problem with the Samsung? I've looked into the different bands/Hz and can't ascertain what I should change to stop it from happening. I've also tried being over 150m away from the other receiver but it seems to still interfere.

I don't really want to use Airplane mode as I want full control and use course lock during the 10-15 minute flight time.

Any ideas of what I could test out would help a lot.

Samsung Phone/DJI app/Firmware all up to date.

Thanks guys.
 

Attachments

Logger

Well-Known Member
Joined
Dec 1, 2016
Messages
1,130
Reaction score
597
Age
55
..... I don't really want to use Airplane mode as I want full control and use course lock during the 10-15 minute flight time.

Any ideas of what I could test out would help a lot..
Put the S9+ in aeroplane mode. Doing so will have no effect on control of the Mavic or your ability to use course lock. Having the phone radios off will rule interference from them out.
Borrow an iPhone from someone, install DJIGo4 on it and fly the sorty again with an iPhone. Verify the interference to the trackers still occurs. This will rule the Samsung out as the cause.
 
  • Like
Reactions: dizzy11

dizzy11

New Member
Joined
May 14, 2018
Messages
2
Reaction score
0
Age
31
Sorry for the late reply!

Thank you for the tip; I'll try putting it in Aeroplane mode and test it out. I mistakenly thought it disabled the course lock feature.

I've tried using my iPad with DJIGo4 installed and there was no interference so I figured it was the Samsung.

Thanks for the tip; I'll try it out