Get the most from your Mavic
Join thousands of Mavic owners helping each other
Join Us Now

Dji Go 4 - is a no go.

tstillman

Member
Joined
Jul 23, 2018
Messages
11
Reaction score
6
Age
68
I just received my MPP last week. After reading of the challenges with using it with an Android phone I purchased a iPad mini 4, and got it today.

My problem now is when I tried to download the Dji Go 4 app from the App Store, I get an error message that it's not compatible with my iPad and won't install. When I checked the app date it indicates it's newly updated as of today.

Any insight anyone can share would be great. I must add that I'm not only a novice drone pilot, but I have ever less experience with Apple products, I've always had Android phones. I just want to go flying.
 
  • Like
Reactions: Drgnfli

Just_nick

Well-Known Member
Joined
Jan 29, 2018
Messages
666
Reaction score
458
I'm going to tell you right off the bat, the iPad Mini 4 is a poor decision for a tablet unless you really want to use it in the stock mounts and refuse to buy a larger mount. It has 4-year-old processor with a more expensive screen repair and less brightness than the 5th and 6th gen iPad. I would personally return it, because then you get over twice the performance and you'll likely solve this problem.

If you don't want to do that, I'd say reset the tablet and see if the problem is fixed.
 
  • Like
Reactions: tstillman

mtnd3w88

Active Member
Joined
Aug 24, 2017
Messages
29
Reaction score
8
Age
50
Good Evening,

I just downloaded the DJI GO 4 app on my Ipad mini 4.. everything went fine.(I did a fresh reformat back to factory) I guess I would reset your device back to factory and try again. Also make sure you are downloading the correct app, as there are a couple dji go apps listed when i downloaded mine.
Good Luck.....
 

Lake_Flyer

Well-Known Member
Joined
Jun 8, 2017
Messages
1,138
Reaction score
608
Age
62
Your iPad Mini4 should easily run GO4. Even my Mini2 still does fine. mtn3w88 is right, do a refresh and see how it goes.
 
  • Like
Reactions: tstillman

Darrell2

Active Member
Joined
Jul 8, 2018
Messages
34
Reaction score
10
Age
55
Check your GB I just bought one and I don't have a problem.But mine is 128 GB I had a older Ipad 4 that was a 32 GB and it was not big enough for DJI go.
 
  • Like
Reactions: tstillman

Mymgb

Well-Known Member
Joined
Nov 3, 2017
Messages
175
Reaction score
75
Age
74
I use an iPad mini4 from Apple refurb store. I do mount it in the controller both for MAVIC and Spark.works good for me but does get hot during second battery. I also use a screen shade that wraps around iPad to block sun
 

Kilrah

Well-Known Member
Joined
Nov 12, 2016
Messages
5,747
Reaction score
3,038
Age
37
Location
Switzerland
Latest version still loads happily on my Mini 4 running iOS 11.3.1.
Make sure you actually got a 4 and were not shoved a previous model...
 
Last edited:
  • Like
Reactions: tstillman

4wd

Well-Known Member
Premium Pilot
Joined
Oct 12, 2016
Messages
2,087
Reaction score
1,075
Location
N.Y.Moors
Check your GB I just bought one and I don't have a problem.But mine is 128 GB I had a older Ipad 4 that was a 32 GB and it was not big enough for DJI go.
You must have had a lot of other stuff in there.
It is a demanding app but 'only' about 200mb in size.
However it wil need a couple of GB free for storing data from flights.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,809
Reaction score
2,257
Age
56
the "If you update anything update everything" rule comes into play here.
New ipad, make sure it is updated to the latest IOS
New MP, make sure the firmware is up to date.
The latest GO4 wouldnt load on the Ipad I always used because the update was for the new IOS update. I forgot to update that ipad with the IOS when it came out, but after the IOS update the DJIGo loaded fine.
 

tstillman

Member
Joined
Jul 23, 2018
Messages
11
Reaction score
6
Age
68
Check your GB I just bought one and I don't have a problem.But mine is 128 GB I had a older Ipad 4 that was a 32 GB and it was not big enough for DJI go.
I suspected that memory size was the issue, and your comment confirmed it.

What is the minimum memory requirement necessary to run Go4. (Not that I'm looking to use minimum, but need to know where to start.) Thanks
 

tstillman

Member
Joined
Jul 23, 2018
Messages
11
Reaction score
6
Age
68
Thanks everyone for your comments. I have a place to start now.
 

Kilrah

Well-Known Member
Joined
Nov 12, 2016
Messages
5,747
Reaction score
3,038
Age
37
Location
Switzerland
You don't need more than 1GB free for installing. What he said is completely wrong, you can very well use the app on a 16GB iPad.
 

tstillman

Member
Joined
Jul 23, 2018
Messages
11
Reaction score
6
Age
68
You don't need more than 1GB free for installing. What he said is completely wrong, you can very well use the app on a 16GB iPad.
Interesting, when I tried to download it I got this message.
I also confirmed ios as 9.4.1, IMG_20180804_100145489_HDR.jpeg
 

Taylor1430

Well-Known Member
Joined
Mar 30, 2018
Messages
155
Reaction score
83
Age
46
Just out of curiosity, are you certain it’s a Mini4. I had the same thing happen on and older model mini2 when I first bought my MP. Needed a more current model. Sounds silly but make sure it’s a 4 you actually have.
 

Kilrah

Well-Known Member
Joined
Nov 12, 2016
Messages
5,747
Reaction score
3,038
Age
37
Location
Switzerland
Yup, that's what I mentioned earlier already but he didn't reply. Need to look at the actual model number on the back (Model Axxxx)
 

cornz

Well-Known Member
Joined
Jul 19, 2018
Messages
55
Reaction score
13
iOS 9.4.1 doesn't exist, the latest iOS9 release is 9.3.5...

Anyway you should update to current.
Mine is 9.3.5 and it wont work either.
I have always said crApple devices, were, well, crap. Bought by people with more sense than money.
There is NO technical reason why it wont work other than crApple's walled garden and enforced hardware upgrade policies.
My old Android tablet has no such issues.
 
  • Like
Reactions: tstillman

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,103
Reaction score
580
Age
62
Location
Peterborough, UK
Mine is 9.3.5 and it wont work either.
I have always said crApple devices, were, well, crap. Bought by people with more sense than money.
There is NO technical reason why it wont work other than crApple's walled garden and enforced hardware upgrade policies.
My old Android tablet has no such issues.
Ahh, the old “Apple is crap, Android rules ok” argument..... AGAIN!
My iPad 2018 & iPhone X both run the latest (updated yesterday) DJI Go 4 and have absolutely no problems at all. Go search all the threads where Android users are having all sorts of issues.
 

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,103
Reaction score
580
Age
62
Location
Peterborough, UK
Interesting, when I tried to download it I got this message.
I also confirmed ios as 9.4.1, View attachment 43202
Considering that the current iOS version is 11.4.1, I suspect that it might not be so much that DJI Go is incompatible with your device, more the operating system.
 
  • Like
Reactions: Kilrah
All E RC Mavic Drones

New Threads

Forum statistics

Threads
80,172
Messages
928,371
Members
108,431
Latest member
Stepipeppi