DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

brownie

New Member
Joined
Jul 12, 2017
Messages
2
Reactions
0
Age
33
New here and in need of some help...

I bought my Mavic Pro drone three days ago.
After multiple attempts by both myself and a more experienced friend, I still have not managed to get my iPhone/DJI Go App to connect to my drone. Have not be able to connect OR get a camera feed.

Current status + things I have tried:

Mavic Pro - Fully Charged, operational, gimbal cover and clamp off, flashing yellow taillight

Controller- Fully charged, operational and displaying the DJI Go 4 app flight interface. But with no video feed.
I have separately tried both the out-of-the-box controller cord AND with a iPhone cord through the bottom USB port.

iPhone 6s - Fully updated. Fully functional. Phone connects perfectly to all other devices. (No pocket lint in the port.)

DJI Go 4 App is the most up to date.
I hit "Enter Device" on the Mavic page and can see the flight interface. GPS location is correct and seems totally functional. In the top left corner the status bar is grey and says 'Disconnected'. And there is NO camera feed. (See attached screenshot)
Have restarted and also deleted and reinstalled the app multiple times.

I've tried navigating through the controller menu and selecting "Linking Remote Controller" and selecting "OK" to 'Link RC?". And pressing the button beside the RC switch on the drone.

The strange part, the drone will fly without my phone. And friend of mine used his cellphone and DJI Go 4 app with my remote and drone. And if flew perfectly.

What is going on here?!
RC cable issue? Am I doing something wrong?


Would love to help resolving this.

Look forward to hearing!
 

Attachments

  • IMG_0964.PNG
    IMG_0964.PNG
    247.7 KB · Views: 32
Last edited:
If using USB on bottom of controller, make sure unused cord on side not plugged in too.

Thank you- I tried with the top left DJI RC cord. No luck.
Unplugged top left and tried through the bottom with an iPhone cord. No luck.
Tried the bottom with a no-name/generic Lightning cable and it worked.

However, I want to top left port to work.
After 2 hours talking to them their tech support they think it's a bad RC cable.

But why would it work with my friends phone?

They want me to wait 10 days for a replacement. In the hopes that it works.
10 days from now I'll be away on the trip that I bought this for.
 
First turn on the RC, put the flight mode ON in your iPhone and then log it to RC (you will hear a sound), then start the DJI app and wait for RC connected. Finally start the drone.
 
Maybe try polarpro mount and use bottom USB cord that works Best buy Is selling them in stores for 25. At least you'll have a setup that works for vacation.

Best of luck.
 
I have encountered this a couple times. Changing the power-up sequence solved it for me.
Sequence that worked for me -- Start RC > Start Mavic > Start GO4 App > Plug cable into phone.
 
I'm having the same issue as you. iPhone 6S won't connect. Have tried everything. Talked with DJI tech support, multicopter tech support, apple tech support, even reset my iPhone. Loaded litchi app. No luck. My IPad Pro will not connect either. My sons each have IPhone 6's. My wife has an older iPhone probably a 5, and a complete stranger let me try his iPhone 7. They all connect flawlessly and immediately. Still looking for help here.
 
New here and in need of some help...

I bought my Mavic Pro drone three days ago.
After multiple attempts by both myself and a more experienced friend, I still have not managed to get my iPhone/DJI Go App to connect to my drone. Have not be able to connect OR get a camera feed.

Current status + things I have tried:

Mavic Pro - Fully Charged, operational, gimbal cover and clamp off, flashing yellow taillight

Controller- Fully charged, operational and displaying the DJI Go 4 app flight interface. But with no video feed.
I have separately tried both the out-of-the-box controller cord AND with a iPhone cord through the bottom USB port.

iPhone 6s - Fully updated. Fully functional. Phone connects perfectly to all other devices. (No pocket lint in the port.)

DJI Go 4 App is the most up to date.
I hit "Enter Device" on the Mavic page and can see the flight interface. GPS location is correct and seems totally functional. In the top left corner the status bar is grey and says 'Disconnected'. And there is NO camera feed. (See attached screenshot)
Have restarted and also deleted and reinstalled the app multiple times.

I've tried navigating through the controller menu and selecting "Linking Remote Controller" and selecting "OK" to 'Link RC?". And pressing the button beside the RC switch on the drone.

The strange part, the drone will fly without my phone. And friend of mine used his cellphone and DJI Go 4 app with my remote and drone. And if flew perfectly.

What is going on here?!
RC cable issue? Am I doing something wrong?


Would love to help resolving this.

Look forward to hearing!
Sorry,my question has nothing to do with your issue....... excuse my ignorance, but how do you post a question here ? I do not see any link to post a help question.
 
Go to Forums, click on then find the one you want to post in.
Scroll to bottom and you will see new thread button, click on that and off you go.
I really appreciate your efforts to help but still nothing. I go to the forum i want to post in, scroll down and i see other members posts fine, keep scrolling down to bottom of page and see nothing but advertising.... no button to post !
 
IMG_0255.PNG
I really appreciate your efforts to help but still nothing. I go to the forum i want to post in, scroll down and i see other members posts fine, keep scrolling down to bottom of page and see nothing but advertising.... no button to post !
Have a look at the above, just above Airvoz. Post new thread, click on that.
 
In reply to the linking issue of side port or bottom USB port I found a fix for my problem, at least. I was able to link using the short cord that came with Mavic between the side mount and my Note 4 Samsung phone. All good. As soon as i disconnected the side cord from the RC and plugged in the bottom USB port using about a 2 or 3 foot micro cord from same phone to USB bottom, it wouldn't link no matter what I did. Then........... I switched cords from the "average garden variety" 2 to 3 ft or so cord to the 1 ft. short cord that came with the Mavic, IT WORKED!!!.. I'm not sure at this point if it's the fact I'm just using a shorter cord or if there's something special about the cord that came with the Mavic. Let me know if I'm missing something here, but glad it now works with the bottom port to my Note 4. Marc Trainor.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
131,060
Messages
1,559,406
Members
160,044
Latest member
ken28e