DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

I can’t switch my Mavic Mini to 5.8GHz.

Nawfaal

Member
Joined
Nov 4, 2019
Messages
9
Reactions
1
Age
27
Location
Mauritius
I have a Spark as well and it works fine on 5.8GHz. But my Mavic Mini shows channels only from 1-11 in Manual transmission mode and I cannot switch it to 5.8GHz when I’m getting high interference on 2.4GHz. Kindly help please :( FYI, I am in Mauritius and again my Spark works fine on 5.8GHz.

258EC0E1-89CA-4D23-82E0-6CDB9C254010.png
 
Obviously he doesn't have the FCC model or else 5.8 is all he'd see. He seems stuck at 2.4, at least in manual mode.
 
  • Like
Reactions: Nawfaal
hey , did it worked , im from mauritius too and im not able to connect to 5.8
Hi,

No not yet. I sent my drone back to the shop and they opened a case for me on DJI Support. Waiting for an official answer :(. Do you see the 5.8GHz channels at least?
 
Hi,

No not yet. I sent my drone back to the shop and they opened a case for me on DJI Support. Waiting for an official answer :(. Do you see the 5.8GHz channels at least?

no :( no 5.8 GHz at all . Tried everything possible . I think we probably got our drones from the same shop. Going to wait till this model gets popular here and see if its a generalized problem. Please keep me updated if they find any solution , i'll do the same on my side. Thank you
 
Solved: I did make "fake GPS position to the Middle of the Europe" on my iPhone. And all of missing channels appeared in my RC.
So that is not RC damage - just software restrictions regarding country you re located at.
Will wait when DJI updated correct allowed RF bands in Ukraine.
 
Hi,

No not yet. I sent my drone back to the shop and they opened a case for me on DJI Support. Waiting for an official answer :(. Do you see the 5.8GHz channels at least?


hi,
got a solution , switched my location to the USA using a fake gps app one the phone ( i used fly gps )
then opened the dji app , switched to manual transmission , got all the 5.6 channels
Then closed the fake gps app to reset the location to the real one . Worked fine

So its a software problem linked to our location , hopefully will be fixed in the next update
Good luck !
 
  • Like
Reactions: Nawfaal
Good tip but given how weak the CE transmission power is in 5.8Ghz mode, it's probably always going to be better to be in 2.4Ghz mode, unless you're flying in massive interference...in a city but then few countries allow that so ;-)
 
hi,
got a solution , switched my location to the USA using a fake gps app one the phone ( i used fly gps )
then opened the dji app , switched to manual transmission , got all the 5.6 channels
Then closed the fake gps app to reset the location to the real one . Worked fine

So its a software problem linked to our location , hopefully will be fixed in the next update
Good luck !
OH MY GOD. IT WORKED! YOU’RE THE MAN! THANK YOU SO MUCH! I’ve been struggling with that for weeks and it’s been driving me crazy since then! Steps I did are as below:
1. Get an Android Phone.
2. Downloaded the Fake GPS Locator from Play Store, the one shown in the attached pictures.
3. Run the Fake GPS service and faked my location to Paris, France.
4. Downloaded and opened DJI Fly on the Android phone with RC connected. Complete the app set up before proceeding to the next step.
6. Turn RC first, then the Mavic Mini.
7. As soon as the RC connects to the drone, quickly enter in Transmission settings before the satellites connect and receive the home point.
8. Switch to Manual and hit on a 5.8GHz channel and VOILA!
9. I then disconnected everything and used my iPhone again and now the 5.8GHz works fine on my iPhone in Mauritius!

Note that it didn’t work with some Fake GPS apps. I had to even try twice with the one I used to get it to work so don’t give up!

I hope this helps other people! Now I can die in peace :)
 

Attachments

  • C102879D-ACA2-4729-A720-90193C4151EC.png
    C102879D-ACA2-4729-A720-90193C4151EC.png
    1.2 MB · Views: 50
  • 38D6765E-D743-4CFD-8FAA-F39DA2367881.png
    38D6765E-D743-4CFD-8FAA-F39DA2367881.png
    1.4 MB · Views: 54
  • 1215E81E-2191-4175-80AC-72D05A8D7A1F.png
    1215E81E-2191-4175-80AC-72D05A8D7A1F.png
    2.1 MB · Views: 55
  • Like
Reactions: blakamin
Solved: I did make "fake GPS position to the Middle of the Europe" on my iPhone. And all of missing channels appeared in my RC.
So that is not RC damage - just software restrictions regarding country you re located at.
Will wait when DJI updated correct allowed RF bands in Ukraine.

Did the same and it worked until mavic was connected to Android, when I switched back to iphone I got switched to 2,4 again. What is the slution?
 
OH MY GOD. IT WORKED! YOU’RE THE MAN! THANK YOU SO MUCH! I’ve been struggling with that for weeks and it’s been driving me crazy since then! Steps I did are as below:
1. Get an Android Phone.
2. Downloaded the Fake GPS Locator from Play Store, the one shown in the attached pictures.
3. Run the Fake GPS service and faked my location to Paris, France.
4. Downloaded and opened DJI Fly on the Android phone with RC connected. Complete the app set up before proceeding to the next step.
6. Turn RC first, then the Mavic Mini.
7. As soon as the RC connects to the drone, quickly enter in Transmission settings before the satellites connect and receive the home point.
8. Switch to Manual and hit on a 5.8GHz channel and VOILA!
9. I then disconnected everything and used my iPhone again and now the 5.8GHz works fine on my iPhone in Mauritius!

Note that it didn’t work with some Fake GPS apps. I had to even try twice with the one I used to get it to work so don’t give up!

I hope this helps other people! Now I can die in peace :)

Isn't working in my Mavic Mini :(
My location is in Indonesia, only get 11 channel for 2,Ghz & no 5,8 Ghz
 
Isn't working in my Mavic Mini :(
My location is in Indonesia, only get 11 channel for 2,Ghz & no 5,8 Ghz

Mas, are you using iPhone or Android. I had the same problem here in the Philippines. I only got 2.4ghz bands in my iPhone.

If Android, check the post here on installing FlyApp 1.1.2 and you will get the 2.4ghz and 5.8ghz bands. Then you can update back to the latest FlyApp version.

If you are using iPhone like what I am using, I downloaded the FlyApp 1.1.2 to an Android phone and entered my username and password. After than, I closed it and when I opened the FlyApp in my iPhone, I already have both 2.4ghz and 5.8ghz bands. I already posted the steps with some pictures in another thread

:D
 
Mas, are you using iPhone or Android. I had the same problem here in the Philippines. I only got 2.4ghz bands in my iPhone.

If Android, check the post here on installing FlyApp 1.1.2 and you will get the 2.4ghz and 5.8ghz bands. Then you can update back to the latest FlyApp version.

If you are using iPhone like what I am using, I downloaded the FlyApp 1.1.2 to an Android phone and entered my username and password. After than, I closed it and when I opened the FlyApp in my iPhone, I already have both 2.4ghz and 5.8ghz bands. I already posted the steps with some pictures in another thread

:D
Hi, Did you mean I have to downgrade the DJI FLY? ?I'm using the latest version (1.1.9)
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

Forum statistics

Threads
129,938
Messages
1,547,678
Members
158,996
Latest member
fotoklasika