DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

New twist on old problem?: No POI mode on iPad but have it on Android!

Air Or

Active Member
Jan 30, 2018
After going through the 2017 threads about getting POI mode to show up, ensuring the airplane is in P mode, not Sport mode, enabling Intelligent Flight Modes, (or turning Intelligent Flight Mode off if it was on -which worked for a few people), looking for the IFM menu when aloft instead of on the ground, nothing worked. I couldn't get past the initial 4 flight modes showing up, and I wanted POI!!

I was initially running the prior firmware, then updated to most recent DJI firmware from 7/4/2018, controller into an iPad 9.7" model A1474 running iOS 11.4.

Nothing was working.

Just as a lark, I thought I'd try using my Samsung Galaxy7 as a controller screen instead of the iPad. Some users had posted about problems with some phones so I figured, what's the harm?


The intelligent Flight Modes were appearing just where they were supposed to. Switched back to the iPad, and nope! No Intelligent Flight Modes.

So there's the dilemma. The iPad has the 9.7" screen but no Intelligent Flight modes menu. The Samsung has the Intelligent Flight Menu but a dinky screen.

What's the fix?

Edit: I found it! See below----
Last edited:
OK OK OK I think I've got this thing solved.

As another "what can it hurt" step, I deleted the DJI Go4 app from the iPad and then reinstalled it.

After re-connecting with my DJI account, went through the tutorial then up came the "You are about to enable Intelligent Flight Mode" dialog. Do you agree? Hit yes.

Took off up to 150', opened the Flight Modes menu on the left, and now (magically) the menu slides to the left to reveal the rest of the modes including the POI mode, the one I wanted about 4 hours ago.

Perhaps someday this first post and solution will help someone.
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Latest member