DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Litchi gimbal control is going nuts

roadkilt

Well-Known Member
Joined
Nov 2, 2016
Messages
98
Reactions
88
Age
73
I have been flying test loops with Litchi in Waypoint under different scenarios. I'm getting flights where i have a POI and only a handful of waypoints, constant height, and the gimbal swoops up to the sky and down to the ground and then back like its searching for something. Doesn't do it in Go 4.2, if I go into FPV in Litchi the gimbal roller switch is almost random and not "sensitive" to throw. Anyone have these issues, and/or a solution? Litchi help is non-existent on their website.
 
Yes , exactly the same problem . I found your post after googling Mavic Litchi gimbal problems . Works ok with DJI Go4 but gimbal goes crazy flying waypoints in Litchi . Constantly moves up and down to its limits :(
 
My problem with Litchi gimbal is that, while doing a waypoint mission I can NOT control the gimbal pitch. It works fine on the P3P, but Mavic is locked. So no small adjustments while the waypoint mission is flying. When I mailed Litchi support they said: "Restarting your aircraft and app should fix it.". Well it does not fix it, still broken.
 
Same here when the Gimbal control in Focus POI mode. I tried the same mission with Gimbal control in Disabled, Focus POI and interpolate and only Focus POI is having the issue. Interpolate works ok.
 
Just wanted to add to the thread that I am experiencing exactly the same thing. So it doesn't seem to be an isolated problem you had. Wish I had found this thread before paying for Litchi. :mad:
 
Got the same issue too....for me while using VR...works fine then for no reason starts to roll up and down of it's own free will.... sometimes it settles after a several cycles but is scares me to think if I was in immersive mode too.

Have noticed that sometimes this seems to coincide with video stream interference but not always.

Not sure if its related but I also noticed that yaw and rudder controls also seemed to become hypersensitive today and also the "record" mode was not being displayed at all or after a delay in my goggles...almost seemed like it's command buffer was overloaded creating a lag in responses??

(Am using a Samsung S5 with Android 6 (no other apps running)
 
Mine corrected itself when I used a better phone to run the app . I was initially using an older Galaxy S4 but Litchi support said it sounded as if the processor could not keep up with the gimbal commands. I guess they were right as since switching to a Droid Turbo Litchi has run flawlessly .
 
when the Gimbal control in Focus POI mode

That's kinda the point of the "Focus POI" mode though. If you tell Litchi to control the gimbal pitch to look at the POI according to the POI altitude vs the Mavic altitude and distance, then of course it will interfere with you trying to fiddle with the gimbal pitch also. Maybe this was confusing... they shouldn't use the word focus (meaning "look directly at") because people think focus ("blurry or sharp").

If you set "Disable" gimbal pitch control, then the pilot can control the pitch.

If you set "Interpolate" gimbal pitch control, then it will try to smoothly control the gimbal pitch gradually ramping between the settings on the prior and next waypoints.

If you set "Focus POI" gimbal pitch control, then it will control the gimbal pitch directly so it aims at the POI.
 
That's kinda the point of the "Focus POI" mode though. If you tell Litchi to control the gimbal pitch to look at the POI according to the POI altitude vs the Mavic altitude and distance, then of course it will interfere with you trying to fiddle with the gimbal pitch also. Maybe this was confusing... they shouldn't use the word focus (meaning "look directly at") because people think focus ("blurry or sharp").

If you set "Disable" gimbal pitch control, then the pilot can control the pitch.

If you set "Interpolate" gimbal pitch control, then it will try to smoothly control the gimbal pitch gradually ramping between the settings on the prior and next waypoints.

If you set "Focus POI" gimbal pitch control, then it will control the gimbal pitch directly so it aims at the POI.
I think you misunderstand the issue. The issue was when we set the gimbal pitch control to "Focus POI", it doesn't NOT control the gimbal pitch directly to aim at the POI. It was simply bouncing up and down crazy. The issue was fixed in the latest Litchi update. Now it is working as you have mentioned.
 
I can confirm that. From time to time the gimbal wents absolute crazy, repeately pitching up and down for no reason.
 
Im having the same problem, moving up and down untill i almost throw up..
I drove the same route and the bouncing kept going but started between other later checkpoints, always if there is POI in my routes.
Have any found a solution?
 
Don't use it. I use only Autopilot or fly manual. And by trying to fly manual, you really get the hang of filming in circles.
Funny, I use to fly all in waypoint mode but more and more I fly in manual mode or other intelligent modes. Like orbit. But I can fly orbit mode as easily by myself
 
Have been playing Litchi almost 4 months now trying everything with waypoint mission.

Just today I found out that the gimbal pitch tilt up/down won't work (out of range) if AC lost connection with RC. Is this a glitch? :(
 
hi , i've had this too - randomly. I ran the same mission twice and the gimbal went out of control at 1 waypoint in first run then at 2 different waypoints in the second run. Makes any footage unusable. Doesn't do it on every mission. I always use POI setting yet the gimbal goes crazily up and down. Trying to lock the gimbal scale on screen doesnt stop it. I'm using a samsung s5 but will be using a (newer) note 4 from now so will advise if the suggestion - that only older devices are affected by this due to processor power - is right or not. i've logged twice with Litchi but no reply yet.
 
Have been playing Litchi almost 4 months now trying everything with waypoint mission.

Just today I found out that the gimbal pitch tilt up/down won't work (out of range) if AC lost connection with RC. Is this a glitch? :(
hi - you're right - it states this in Litchi 'help' page. You can also not control the gimbal if using POI as a mission setting
 
Hi Here's Litchi's helpful reply on how to avoid gimbal 'out of control' issues when using waypoint:

"Older devices may not be powerful enough to run Litchi correctly and this can lead to the gimbal moving unpredictably. To improve the performance of your mobile device, please follow these guidelines: - make sure there are no apps running in the background before you start Litchi - make sure your mobile device is not in power saving mode (has various names on Android; called "Low Power Mode" on iOS) - disable Internet (for example switch to airplane mode) to prevent the DJI development kit to continuously send analytics data while you fly - make sure the Histogram is disabled (camera setting) - do not use screen recording as that will increase the requirements a lot - make sure "Full HD Stream" is disabled in the camera settings (for Mavic Pro/P4 Pro/Inspire 2) - make sure there are no interferences where you fly .Also keep in mind that gimbal movements when signal is lost is undefined."
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Members online

Forum statistics

Threads
130,059
Messages
1,548,837
Members
159,113
Latest member
reedyjt