DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Gimbal Drift AND Panorama Failures (Android/Google Pixel 2)

DanielSon

Member
Joined
Feb 5, 2018
Messages
15
Reactions
0
Age
31
Hey fam, looking for some help.

I have done the IMU, Compass, and Gimbal calibrations in different orders a multitude of times indoors and out and I still have massive gimbal horizon drift. It's off by 5+ deg to either side throughout flight. Horizon tilts when I have any yaw input, or it just drifts around on it's own accord. Yay! Just like my P3P which I finally sold to buy the Air, hoping that DJI didn't have every single one of their cameras still having gimbal drift issues. Bleh.

Secondly, panos aren't working well. SOMETIMES I can get a horizontal pano to stitch in-app, but that's it. Spherical panos finish shooting, and then just either give a failed error, OR they just sit there at 100% and never finish processing. I have to land the aircraft and either disarm/rearm or even reboot for me to be able to take another picture. (The shutter and settings buttons are greyed out until I do).

The individual photos will save to the SD card, but not the stitched pano. I have tried shooting with the "save images on SD card" off, and the same results - just fails to finish the pano or it "finishes" but gets hung up at the very end.

Mostly like this thing - but the two big reasons I bought it (Panos and a reliable gimbal), are both of the failing points at the moment. Sadness.

The drone, app, phone (8.1), controller, etc are all updated to most recent firmware. Any help is more than welcome!
 
Ill check this tomorrow as well,... did you had any vrash or something with the gimbal? If you do the calibration et works fluently roght?
 
Vrash?? Crash?

No crashes - brand new out of the box, the gimbal calibrates fine and works normally, but the roll drifts to the left and right randomly. (On the table indoors, and while in flight)
 
Vrash?? Crash?

No crashes - brand new out of the box, the gimbal calibrates fine and works normally, but the roll drifts to the left and right randomly. (On the table indoors, and while in flight)
Yes sorry, crash. I shouldnt text while brushing my teeths ;) well well,... firmware update? Maybe that helps?
 
I am getting very blurry pictures. As if they are from cache. The individual pictures are very sharp. So far DJI or forums can’t help
Thats odd, is your lens clean and clear of any dust etc? Take a picture of a white wall or a clear blue sky and zoom in on the computer to look for artifacts. Could be a dirty or faulty camera or lens.

OR do you mean the final panorama is blurry? Do you have examples?
 
Hi. Problem solved. Turns out I shared the tiny planets before downloading.
Thanks
 
Which issue are you having?
Constant gimbal drift and when I am trying to take Panos it will take one pic then freeze up, locking me out of the camera function. I have to fly home, land, reset, launch and return.
 
Constant gimbal drift and when I am trying to take Panos it will take one pic then freeze up, locking me out of the camera function. I have to fly home, land, reset, launch and return.
What device are you using?
 
Hey fam, looking for some help.

I have done the IMU, Compass, and Gimbal calibrations in different orders a multitude of times indoors and out and I still have massive gimbal horizon drift. It's off by 5+ deg to either side throughout flight. Horizon tilts when I have any yaw input, or it just drifts around on it's own accord. Yay! Just like my P3P which I finally sold to buy the Air, hoping that DJI didn't have every single one of their cameras still having gimbal drift issues. Bleh.

Secondly, panos aren't working well. SOMETIMES I can get a horizontal pano to stitch in-app, but that's it. Spherical panos finish shooting, and then just either give a failed error, OR they just sit there at 100% and never finish processing. I have to land the aircraft and either disarm/rearm or even reboot for me to be able to take another picture. (The shutter and settings buttons are greyed out until I do).

The individual photos will save to the SD card, but not the stitched pano. I have tried shooting with the "save images on SD card" off, and the same results - just fails to finish the pano or it "finishes" but gets hung up at the very end.

Mostly like this thing - but the two big reasons I bought it (Panos and a reliable gimbal), are both of the failing points at the moment. Sadness.

The drone, app, phone (8.1), controller, etc are all updated to most recent firmware. Any help is more than welcome!
Not sure whats wrong with your Air but here's some insight. When the MP first launched there were a lot of gimbal issues, plenty of people got free replacements since DJI admitted fault. If you can't find a solution it might be the answer. I hated my MP gimbal. Had horizon slant and sometimes wobbled. My MA has no issues.
 
Not sure whats wrong with your Air but here's some insight. When the MP first launched there were a lot of gimbal issues, plenty of people got free replacements since DJI admitted fault. If you can't find a solution it might be the answer. I hated my MP gimbal. Had horizon slant and sometimes wobbled. My MA has no issues.
It's a Pixel 2.

I might have to go the replacement route, this is already my second Air, I got the standard pack originally used it for a few weeks with no issues. Then the fly more came on special for only 200$ more than i paid so I got a refund using the "they took my waypoints" excuse. Now the new one has plenty of issues.
 
It's a Pixel 2.

I might have to go the replacement route, this is already my second Air, I got the standard pack originally used it for a few weeks with no issues. Then the fly more came on special for only 200$ more than i paid so I got a refund using the "they took my waypoints" excuse. Now the new one has plenty of issues.

I also have the same problem with the asteroid mode SOMETIMES, the thing locks up at the very end and I need to come back and land/reboot. Alternatively - I noticed if I am in SPORT mode and I hit the pano shutter button, it freezes up and I have to land. Make sure it is not in sport mode when you hit the shutter. At least on pano modes at the moment. :(

I did have some success with the gimbal drift issue. I did a factory reset and all firmware updates again via the DJI Assistant 2 app on a PC (it didn't work on my macbook for some reason, ugh.). I then did a fresh IMU calibration on a perfect level surface, compass calibration, and gimbal calibration. I had to adjust the gimbal roll by 1.5 or so, but otherwise it holds it's horizon now. Pano mode works, asteroid mode works (just make sure it's not in sport mode).

The remaining issues (these issues were the same on my Pixel 2 as they were using an iPad air, so I don't think it's Pixel related):
1) I get the green/pink lines on the edges of the finished asteroid - super unsightly. See here:

2) The jpeg photos and video still have a warp issue of the lens, but this has been covered in other threads as a problem across all or most units...waiting on a software fix for that. This MIGHT be the cause of my panos (spherical and horizontal) to stitch terribly with a rollercoaster of a horizon. I still need to try another set of panos with the gimbal tilt extension disabled, I got too busy and we got like a foot of snow this weekend.
 
Those pink lines took me by surprise, that's heinous, I'll have to check mine tonight. I haven't noticed a warp in my lens except for a curved slightly horizon and some vignetting. Thanks for the tips, I'll try do the whole sequence once I'm home from work. Will post any success or failure.
 
Those pink lines took me by surprise, that's heinous, I'll have to check mine tonight. I haven't noticed a warp in my lens except for a curved slightly horizon and some vignetting. Thanks for the tips, I'll try do the whole sequence once I'm home from work. Will post any success or failure.
Yeah I haven't seen ANYONE else's asteroid turn out like mine so I'm pretty stumped!
 
Well that plan faield, Assistant 2 will not work. Says I have a 2-3 connected, when I hit it I just get a white screen.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,086
Messages
1,549,140
Members
159,139
Latest member
MonsterMagnet31