DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Please help! 0x800000 error, no Gimbal Status option in the Options menu and no SD card.

Ram85

Well-Known Member
Joined
Mar 14, 2019
Messages
74
Reactions
37
I purchased a second-hand Mavic 1 pro recently with the owner stating that it needed a gimbal ribbon replacement. It was a good price so I figured I could try and fix it as a project.

I have an issue after replacing the gimbal ribbon and video cable. I still get the 0x800000 error but the strangest thing is that in my DJI Go 4 app there is no Gimbal Status option in the Options menu.

The gimbal powers on during startup, but I still don't have any video feed nor am I able to move the gimbal up or down. Original SD card not detected as well. Telemetry displays fine.

Does anyone know how to resolve this?

73231
 
When I try and refresh the firmware or downgrade via DJI Assistant I get to 40% then it fails with UNIDENTIFIED 0x020104 error.
 
I purchased a second-hand Mavic 1 pro recently with the owner stating that it needed a gimbal ribbon replacement. It was a good price so I figured I could try and fix it as a project.

I have an issue after replacing the gimbal ribbon and video cable. I still get the 0x800000 error but the strangest thing is that in my DJI Go 4 app there is no Gimbal Status option in the Options menu.

The gimbal powers on during startup, but I still don't have any video feed nor am I able to move the gimbal up or down. Original SD card not detected as well. Telemetry displays fine.

Does anyone know how to resolve this?

View attachment 73231
That means the gimbal isn’t communicating with the app. The app basically doesn’t asks the gimbal, “what are your capabilities? And the gimbal responds back. If the gimbal doesn’t respond the app doesn’t think there is a gimbal.
 
That's why I'm trying to upgrade /downgrade the firmware but it keeps failing at 40% using dji assistant. With dumldore the flash completes and says the drone can be turned off... But the firmware version does not change.

Another thread with almost exactly the same issues I have: DJI Mavic Pro Gimbal disconnected
 
Check if gimbal ribbons are properly connected to the top gimbal board (under the top shell in the front).
 
That's why I'm trying to upgrade /downgrade the firmware but it keeps failing at 40% using dji assistant. With dumldore the flash completes and says the drone can be turned off... But the firmware version does not change.

Another thread with almost exactly the same issues I have: DJI Mavic Pro Gimbal disconnected

It’s probably failing because the gimbal isn’t connected and so it can’t get through that part of the upgrade process
 
Currently on the latest version 1.04.0500 and I'm trying to just refresh it(reflash), I've tried going to 1.04.0300, 1.04.0100 and 1.03.0700... No luck.

Based on the issues and that link I posted I'm getting more and more sure it's a bad firmware flash. I have all the same syntoms as he did.
 
Currently on the latest version 1.04.0500 and I'm trying to just refresh it(reflash), I've tried going to 1.04.0300, 1.04.0100 and 1.03.0700... No luck.

Based on the issues and that link I posted I'm getting more and more sure it's a bad firmware flash. I have all the same syntoms as he did.

Well unless you are using dumldore you can't just downgrade like that. Thats why it failed one of the reasons it failed. It really sounds like your gimbal is not connected properly. Why is it you think this has to do with the firmware? The firmware is probably fine you just need to get the gimbal connected.

When the drone starts up and the gimbal goes through its start up sequence does it make chiming sound like "da, da ,DA" or is silent?
 
I have tried Dumldore... as stated above it completes every time without any issues but the firmware does not change / take effect.

I've opened the gimbal again and check the gimbal ribbon cable, it is seated correctly as well as the video cable. I'm not able to pan up or down with the gimbal but the gimbal is powered on and working. I'm starting to suspect the gimbal pcb board.

The reason I suspect the firmware is because I'm also getting the No SD card issue. The same issue found here DJI Mavic Pro Gimbal disconnected
 
I have tried Dumldore... as stated above it completes every time without any issues but the firmware does not change / take effect.

I've opened the gimbal again and check the gimbal ribbon cable, it is seated correctly as well as the video cable. I'm not able to pan up or down with the gimbal but the gimbal is powered on and working. I'm starting to suspect the gimbal pcb board.

The reason I suspect the firmware is because I'm also getting the No SD card issue. The same issue found here DJI Mavic Pro Gimbal disconnected

Hmmm, Thats a new one to me. Can it be the app like suggested in the thread you referenced?
 
Hmmm, Thats a new one to me. Can it be the app like suggested in the thread you referenced?
I've tried mulitple devices and apps. litchi, old dji version etc. no luck.

When I try and do a firmware refresh I can only get to 40%... checking I tried to format the sd card and got the "no sd card" notification. I then tried to reset the camera... and got an error stating "tips: camera reset failed"
 
Last edited:
I've tried mulitple devices and apps. litchi, old dji version etc. no luck.

When I try and do a firmware refresh I can only get to 40%... checking I tried to format the sd card and got the "no sd card" notification. I then tried to reset the camera... and got an error stating "tips: camera reset failed"
Did you format the SD card in DJI Go 4? What firmware version does it say you are on now?
 
Did you format the SD card in DJI Go 4? What firmware version does it say you are on now?
I cannot format the SD card since the app says "no sd card". I'm currently on 1.04.0500 and as stated earlier I cannot refresh or downgrade... I get to 40% then the drone restarts and the update fails with UNIDENTIFIED 0x020104 error.
 
I cannot format the SD card since the app says "no sd card". I'm currently on 1.04.0500 and as stated earlier I cannot refresh or downgrade... I get to 40% then the drone restarts and the update fails with UNIDENTIFIED 0x020104 error.

Yea sorry man I wish I knew how to help. Sounds like it’s time to have send it to @Thunderdrones or something
 
Yea sorry man I wish I knew how to help. Sounds like it’s time to have send it to @Thunderdrones or something

You get an A for effort trying to help! Wish I had you here working with me.

It sounds like the core board has either been fried or bricked. Thats what the "no sd card" error message usually means.

If the Op wants to start swapping boards, he might start with the core board.
 
  • Like
Reactions: brett8883
You get an A for effort trying to help! Wish I had you here working with me.

It sounds like the core board has either been fried or bricked. That's what the "no sd card" error message usually means.

If the Op wants to start swapping boards, he might start with the core board.

I have received a great amount of advice and help so far. Really appreciate it!

I've attached a picture of what I think is my last option before the core board option.
Would replacing the right(circled in red) flex cable help? if I remove it, it seems like nothing happens. No errors, nothing.
If I remove the left (circled in yellow) flex cable I get lots of errors, which makes me think there is hope.
Please let me know if you think it will help.

Just some info. The drone flys great, bottom and forward sensors all work as they should. VPS(via assistant), GPS and IMU calibrations work/complete without any issues. The only problem I have with the drone is: No video feed and camera information as well as no SD Card.

Trying to reset the camera gives the pop-up: Tips: Resetting failed.
Formatted SD cards using my other mavic pro, pc, phone, and my Nikon camera with no success. I've also tried, 4gb, 16gb, 32gb and 128gb(from my working mavic pro).
Upgrading via Assistant 1.2.1(2,34, and 5) all result in the following. Restoring factory settings always works but when Refreshing or Downgrading current firmware it always fails on exactly 40% with the drone restarting and assistant displaying an upgrade failed: UNIDENTIFIED 0x020104 error.

I've tried using Dumldrore 3.20 as well. It does not error and goes to 40% just like assistant, then restarts the drone and jumps to completed, it then says that it is safe to shut the drone off. So it does not fail or give any errors... but does not flash the firmware...

This is the closest I've found to my current issue as he has almost exactly the same issues as I have and also upgrades fail at 40%.His issue was fixed using a different sd card or formatting it: MP Pro Apparently no Camera/Gimbal Connection
 

Attachments

  • mavic pro 0x8000000 error posibility.jpg
    mavic pro 0x8000000 error posibility.jpg
    1.5 MB · Views: 53
Replacing the exact cable you are referencing as the potential problem is what solved my “no video transmission” issue after replacing the gimbal PCB. Although I didn’t have an sd card issue, It was my last resort before replacing the vision board. The two issues could be related though....
 
Replacing the exact cable you are referencing as the potential problem is what solved my “no video transmission” issue after replacing the gimbal PCB. Although I didn’t have an sd card issue, It was my last resort before replacing the vision board. The two issues could be related though...
Thank you for letting me know. Do you know what that cable is called? This thing seems like a bottomless pit... gimbal ribbon > video cable > gimbal pcb... next "inner flex cable" and if that does not work then the big one... core board...
 
  • Like
Reactions: shot_by_SU
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

Forum statistics

Threads
130,932
Messages
1,558,060
Members
159,941
Latest member
jonesaerial