DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Mghoodlum

New Member
Joined
Jan 31, 2017
Messages
3
Reactions
3
Age
43
Another problem Solved.

I’m not sure what started this but it may have been a firmware update. My mavic would only go 5-6mph in the horizontal plane. It would go up and down much faster. Horizontal movement was very sluggish as well. I tried updating firmware from app, resetting the gain and esc, calibrating the IMU after reading several post. Nothing worked. Hours wasted. I then tested in sport mode and everything worked. After further research I turned off obstacle avoidance and it worked as it should. I know knew it must be a problem with those sensors! To fix I had to recalibrate. To do that I installed the DJI Assistant 2 but I got a message about a failure to load the driver because they were unsigned. When I went into the calibrate portion of the program it would not continue and would just keep saying restart drone. So after multiple attempts I researched how to load the driver. I figured out I needed to restart in troubleshooting mode. I did but then I couldn’t do what I wanted due to hard drive encryption “bitlocker”. So here are the full steps I Tool to resolve issue. Note: This is for a computer running windows 10.

1) Uninstal Assistant
2) Disable Bitlocker hard drive encryption

A. Start/
B. Control Panel/
C. System and Security/
D. Bitlocker Drive Encryption
E. Select Disable
(Note after reboot this will turn back on)

3) Reboot computer in troubleshooting mode by:

A) Hold shift plus restart
B) After reboot choose “Troubleshoot”
C) Advanced Options
D) Startuo Settings
E) Restart

After restart choose option 7. Disable driver signature enforcement.

4) Reinstall DJI Assistant 2
Note: you will need to load drivers despite warning on pop ups they might be unsafe.
5) Connect Mavic through USB cable
6) Turn on
7) Select calibrate and follow prompts until done.


I hope this saves someone else the hours of aggravation I had as I pieced each step together.
 
  • Like
Reactions: Hotelone
I have the same problem with slow fly. Do you solve the problem of slow fly after the calibration?

I guess it can be caused for the front sensor but the closer wall was around 10 meter from the Mavic.
 
Calibrating the optical sensors fixed it for me. You can test by disabling the sensors while flying in the DJI Go app or alternatively just enter sport mode which also disables the obstacle avoidance sensors. If it goes fast then I would guess that calibration should fix the issue.
 
Same exact problem here on my "brand new" refurbished MP Alpine so I'm going to try to recalibrate with DJI Assistant 2...will report back later or tomorrow rather since it's getting dark here !
 
Nope, calibration worked fine but it's still flying like a slug (around 10 km/h) when obstacle avoidance is on. It stops for the trees so the sensors are apparently ok. If I turn off obstacle avoidance it flies like a champ. I'm stumped ! Anyone know what might be going on ? Thanks !
 
I have the same problem it's really slow going forward and calibration didn't fix it did anyone figure this out
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Members online

Forum statistics

Threads
131,641
Messages
1,564,818
Members
160,510
Latest member
pilot74sparki